Boost logo

Boost :

From: Thore Karlsen (sid_at_[hidden])
Date: 2005-09-22 15:21:02

On Thu, 22 Sep 2005 20:54:22 +0100, "Andy Little"
<andy_at_[hidden]> wrote:

>>> How about :
>>> guard.up();
>>> guard.down();

>> ...
>> xyz.up();
>> ...
>> xyz.down();
>> Out of context, and without a variable including (if not ending
>> with) "guard," "up" and "down" don't fit well.

>Is this not this variable always going to be called guard?(For example see
>ScopeGuardTest.cpp in the distro) I assume theres only ever one per scope

No, I routinely have more than one guard per scope.

Be seeing you.

Boost list run by bdawes at, gregod at, cpdaniel at, john at