Boost logo

Boost :

From: Larry Evans (cppljevans_at_[hidden])
Date: 2005-09-28 14:35:34


On 09/27/2005 03:24 PM, Calum Grant wrote:
[snip]
>
> Is there any interest in providing relational containers in Boost? Are
> there any features/improvements you can suggest for RML?
>
I'm having trouble understanding the purpose of table_column_number.
In column_names.hpp, it appears in:

        template<typename Row> struct table_columns { \
                ::relational::table_column_number<Row,0> N0; \
                ::relational::table_column_number<Row,1> N1; }; \

which it looks like you're creating the equivalent of boost::tuple, but
with more meaningful names (i.e. N0 is more meaningful than T0 of boost
tuple because N0 is an argument to the RM_DEFINE_ROW_2 macro). I see
table_column_number defined in expressions.hpp, but I see no member
variables; hence, table_column_number<Row,0> can't be the equivalent of
T0 (the argument to RM_DEFINE_ROW_2 before N0).

Could you explain a little more?


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk