Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-10-07 13:13:49

From: Caleb Epstein <caleb.epstein_at_[hidden]>
> Ergo I restate my case that this library should NOT be called Pimpl. Maybe
> PimplHolder or something like that, but calling it Pimpl confuses at least
> two people :-)

I was never confused as to whether this library would magically
implement the impl class, though I think Asger may have flirted
with the idea of forwarding functions. Nevertheless, I can see
calling the class pimpl_ptr, if that suffix would clarify matters
for you.

That also highlights what Arkadiy--if I remember correctly--
commented on: this is just a special case for a PBSP, with
smart_ptr (in the Review queue) being the likely candidate.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at