From: Matt Calabrese (rivorus_at_[hidden])
Date: 2005-10-15 12:06:17
On 10/14/05, Jeff Flinn <TriumphSprint2000_at_[hidden]> wrote:
> With just reading this description, why not call it what it is:
> binary_literal. Whether it's a template or a macro(in Matt's case) I think
> binary_literal is more descriptive.
That is why I decided to call mine "BOOST_BINARY_LITERAL," however, it was
also suggested that BOOST_BITS may be simpler and possibly just as
descriptive but with less typing. I don't mind either wayt. Right now I
think I prefer that it has "literal" in it, since it's more clear that it is
useable much like other integral literals. In fact, the result is a hex or
octal literal (depending on which version of my macro you look at).
-- -Matt Calabrese
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk