Boost logo

Boost :

From: Andy Little (andy_at_[hidden])
Date: 2005-10-22 10:32:22

Hi Cromwell,

in <boost/mpl/math/rational.hpp>

In the definition for mpl::math::rational would it not be better to make the
nested type member using the numerator and denominator rather than the input for:

typedef rational<integral_c_<int,2>,integral_c<int,8> >::type type;

 currently type is a

     rational<integral_c_<int,2>,integral_c<int,8> >

in the second case type is a

    rational<integral_c_<int,1>,integral_c<int,4> >

I believe the second is superior. Can supply a patch if you like ...

Secondly, are the next and prior members necessary? IMO they only make sense for

Thirdly, It should be noted that there is a <boost/mpl/math/rational_c.hpp>
header, but as rational_c is defined in <boost/mpl/math/rational.hpp> I think
its now both redundant and confusing.

Andy Little

Boost list run by bdawes at, gregod at, cpdaniel at, john at