Boost logo

Boost :

From: Caleb Epstein (caleb.epstein_at_[hidden])
Date: 2005-11-15 00:25:16

On 11/15/05, Caleb Epstein <caleb.epstein_at_[hidden]> wrote:
> Re: capacity/reserve. I think it might be useful to include these methods
> and have them operate on the key array as you suggest. Your argument against
> them is that they are only used to ensure iterator validity. But wouldn't
> these methods also be useful in optimizing container load time, as they are
> for std::vector and friends? I know I always call "reserve" on a vector when
> I know how much data I'm going to load into it ahead of time.

Now that I actually read your entire email it appears that you decided to
support capacity/reserve in the implementation and the spec is out of date.
Sorry for the misunderstanding and not reading your email fully.

As to:

I don't particularly like the name random_access. Do you have an alternative
> proposal? Ideally, a name should be an adjective (like is already the case
> for "ordered", "sequenced", etc.) and capture the essential feature of the
> indices, namely random accessibility.

What aboust "clustered"? It seems a bit like a clustered index in SQL land,
which implies a physical ordering to the data. Unless I'm totally off the

Caleb Epstein
caleb dot epstein at gmail dot com

Boost list run by bdawes at, gregod at, cpdaniel at, john at