Boost logo

Boost :

From: Matt Vogt (mattvogt_at_[hidden])
Date: 2005-12-21 23:08:48

Christopher Kohlhoff <chris <at>> writes:

> I propose that it could be called something like "io_system".
> (Other naming suggestions will be appreciated.)

Based on the statements below, I think io_engine might be appropriate.

> Consider the following statements:
> - An io_system object must be initialised before sockets (or
> other I/O objects) can be used. See the portability
> requirement above.
> - An io_system object is an extensible collection of I/O
> services (drivers?).
> - Synchronous operations implicitly run the io_system object for
> an individual operation.
> - You must run() the io_system object for it to perform
> asynchronous operations on your behalf.
> - You can partition your program by using multiple io_system
> objects.

I wonder if 'service' is the best name for the set of I/O objects encapsulated
by the library, but I can't offer any alternatives...


Boost list run by bdawes at, gregod at, cpdaniel at, john at