Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2005-12-28 21:39:36

"Christopher Kohlhoff" <chris_at_[hidden]> wrote in message

> So what about io_broker? For people who have used CORBA, similar
> rules apply in respect of calling run():
> - No need to call run() in a client making synchronous calls.
> - Need to call run() if using asynchronous method invocation so
> that results can be delivered.
> A possible disadvantage of io_broker is that the name conveys
> too much meaning, in that users may feel it is a concept they
> need to understand before using the facilities it provides. I
> don't think a name like io_services suffers from this.

I have a mild preference for io_services. But io_drivers or some other
variation on Peter's "driver" suggestion would also work for me. For the
"too much meaning" rationale you give, I don't particular like io_broker,
but even that seems better than demuxer, which I always found confusing.

Thanks for worrying about such quibbles - good names do help a library.


Boost list run by bdawes at, gregod at, cpdaniel at, john at