From: Paul A Bristow (pbristow_at_[hidden])
Date: 2005-12-29 05:27:42
| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Beman Dawes
| Sent: 29 December 2005 02:40
| To: boost_at_[hidden]
| Subject: Re: [boost] singleton asio::demuxer
| asdefault?(was:asioformalreview begins)
| I have a mild preference for io_services.
Having racked my brain to come up with a better idea than this or the
several other ideas,
I have strong preference for Beman's original suggestion:
I think it just hits the spot.
The pluralization is entirely unecessary as a 'service' can include many
elements - think 'service' at a restaurant.
And iostream is singular (but lacks the _ so ioservice would be consistent
but not nice?).
'Driver' is a daft name - and always has been IMO.
asio is short and snappy - does it stand for Async AND Sync Input Output?
But is the sync or not that important?
| Thanks for worrying about such quibbles - good names do help a library.
I agree that names are _really_ important.
-- Paul A Bristow Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB Phone and SMS text +44 1539 561830, Mobile and SMS text +44 7714 330204 mailto: pbristow_at_[hidden] http://www.hetp.u-net.com/index.html http://www.hetp.u-net.com/Paul%20A%20Bristow%20info.html
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk