Boost logo

Boost :

From: Paul A Bristow (pbristow_at_[hidden])
Date: 2006-06-07 06:26:07

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Janek Kozicki
| Sent: 06 June 2006 21:09
| To: boost_at_[hidden]
| Subject: Re: [boost] [Review][PQS] Physical
| QuantitiesSystemreview(May31through June 9)
| #include <boost/units/length.hpp>
| I don't care whether it's decided to left out "si_" from the
| name due to
| support of non-si units. Just pick name "units" or "si_units".

I DO care - a lot! Names are REALLY important IMO.

The library IS about units - not just quantities because without units, the
quantity is meaningless.

I think it would be VERY BAD mistake to fix the idea of SI only in the name,
when ALL units (including 'zero' units) can be handled.

"si_unit::length::in" looks plain daft.

Much as SI units are preferable, sadly, other 'traditional' units are never
going to go away.
Lets keep the package as general as possible.

What is important is that using them doesn't result in any more crashes on
Mars, or elsewhere ;-)

And anyway si_units is longer and more annoying to type,

and it raises the doubts should it be SI_units or si_units?

The code also handles units of things that are not really physical, so I
think the PQ bit is also misleading, much as it distresses Andy to lose the
name of his 'baby', so many years in gestation.

So please, lets just stick to 'units' and call the package Boost.Units.


Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539561830 & SMS, Mobile +44 7714 330204 & SMS

Boost list run by bdawes at, gregod at, cpdaniel at, john at