From: Paul A Bristow (pbristow_at_[hidden])
Date: 2006-06-08 07:03:52
| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of David Abrahams
| Sent: 07 June 2006 12:59
| To: boost_at_[hidden]
| Subject: [boost] [Review][PQS] Concept names?
| Aside from nits and naming convention issues,
I am sure that your expertise is invaluable and welcomed here.
| I feel especially strongly that we must not muddle the ideas of generic
Could you elaborate on this?
Are you saying that there is a problem with the documentation, or with the
(Boosters seem to continue to accept vital tools like Test and Build whose
documentation is in a MUCH less than satisfactory state, so I can't see that
this should be grounds for rejecting a submission, only urging its
| I think this is an important domain and I hope we'll be able to accept a
| different version of this library, but, with regret, I vote against
| the inclusion of this one in its current state.
We have been trying for years to get towards a useful solution to this
exccedingly important area,
which has application in 9 out of 10 real-life programs.
The C++ language tantalizingly promises to make possible auto-type checking,
converting and displaying the myriad units, but keeps tripping us up with
vital missing features like typeof, or well fall at the compile speed
What design changes would persuade you to vote for this attempt?
--- Paul A Bristow Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB +44 1539561830 & SMS, Mobile +44 7714 330204 & SMS pbristow_at_[hidden]
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk