Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2006-07-01 12:41:51

> ----- Mensaje original -----
>> I think flyweight is better, although maybe some variant of 'wrapper'
>> might be better.
> Would you care to submit your name proposal in the aforementioned
> format? Although I haven't said it before, it'd be good if
> the namespace did *not* coincide with that of the main utility,
> since it can lead to problems as descibred in
> in connection with the choice of namespace tuples instead of
> namespace tuple.

Sorry I didn't get all that. I was just throwing out some suggestions /
comments...I'll let you handle the details :-)

>> Another question, C# and some other languages have the idea of
>> 'boxing' -- perhaps that's what this really is?
> I don't think so. From my limited knowledge of Java and C#, where
> this term is used, boxing consists of the procedure by which
> a stack-based type is wrapped into a heap-based type so that it
> can be used in certain contexts: for instance, in Java ints cannot
> be used in containers so one has to box them in
> java.lang.Integer's. There's a weak connection with my proposal
> in that (at least in Java) these numeric wrappers are immutable
> and as such candidates for flyweighing techniques. Is this what
> you were referring to, perhaps?

Yep....again just brainstorming some possible names...

> [One final question you didn't address: do you think this worth
> elaborating into a proposal for Boost?]

I think so, but I don't know that I'd have too much use personally.


Boost list run by bdawes at, gregod at, cpdaniel at, john at