From: Pavel Vozenilek (pavel_vozenilek_at_[hidden])
Date: 2006-07-01 12:17:07
"JOAQUIN LOPEZ MUNOZ" wrote:
[ name proposal ]
> Boost.Intern / boost::intern / boost::interned<>
I am not sure whether "intern" is used widely enough.
If I knew such use in the past I did forget it quickly.
One possibly term is Multiton (modeled after Singleton,
meaning pool of unique shared objects, singletons):
(It is infrequently used term and was actually implemented
in deceased Boost.Singleton library.)
As Multiton is obvious loser perhaps the
descriptive "Shared Object Pool"for the library
and "pool" (or "pooled_object" or variant)
for type name may be considered.
"flyweight" is something different from what
the library does and thus not very good term.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk