Boost logo

Boost :

From: Joel de Guzman (joel_at_[hidden])
Date: 2006-07-01 19:40:32

Jeff Garland wrote:
>> Please see my previous answer to Steve Harris. It'd help me
>> a lot if, for uniformity's sake, name proposals could be given
>> in this format:
>> lib name / namespace names / main utility
>> like for instance:
>> Boost.Intern / boost::intern / boost::interned<>
>> So, cast your vote :)
> I have a problem with these names -- Boost.intern sounds like a developer that
> should be working on an SOC project. 'Interned' sounds like what happens when
> someone dies and is buried -- not too pleasant. I think flyweight is better,
> although maybe some variant of 'wrapper' might be better. Another question,
> C# and some other languages have the idea of 'boxing' -- perhaps that's what
> this really is?

I second Jeff. This is also the impression I get with intern, interned.
I've been using the flyweight pattern for a long time now, as a pattern
and not as actual classes, but I wouldn't mind seeing them as such.
I have no problem with it.


Joel de Guzman

Boost list run by bdawes at, gregod at, cpdaniel at, john at