Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2006-07-01 11:52:24


> Please see my previous answer to Steve Harris. It'd help me
> a lot if, for uniformity's sake, name proposals could be given
> in this format:
> lib name / namespace names / main utility
> like for instance:
> Boost.Intern / boost::intern / boost::interned<>
> So, cast your vote :)

I have a problem with these names -- Boost.intern sounds like a developer that
should be working on an SOC project. 'Interned' sounds like what happens when
someone dies and is buried -- not too pleasant. I think flyweight is better,
although maybe some variant of 'wrapper' might be better. Another question,
C# and some other languages have the idea of 'boxing' -- perhaps that's what
this really is?


Boost list run by bdawes at, gregod at, cpdaniel at, john at