Boost logo

Boost :

From: me22 (me22.ca_at_[hidden])
Date: 2006-07-04 10:35:30

On 7/4/06, Emil Dotchevski <emildotchevski_at_[hidden]> wrote:
> > - I don't like the word failed as in 'throw failed<my_error>' it seems
> > strange to throw a "failed error", that's the way I read it anyway. I
> > can't come up with a better one right now though.
> >
> English is not native to me, but the way I read throw failed<read_error>()
> is that the function (that throws) failed due to a read_error. That was my
> intention anyway. :)
failed<read> is quite logical, it's just the failed<read_error> that's
confusing. Of course, read is a bad name for a tag. Also, as soon as
you're throwing, *something* failed, so saying that again doesn't seen
to necessary to me. It's already being said with the throw and the
_error suffix, so the failed name seems like overkill to me.

What about something along the lines of throw after<read_error>(); or
throw because_of<read_error>();, if you want the readability? Or
perhaps throw annotated<read_error>();?

Disclaimer: I haven't really been following what the template is
supposed to do, so I might be way off. I'm just commenting on the
readability point.

~ Scott McMurray

Boost list run by bdawes at, gregod at, cpdaniel at, john at