Boost logo

Boost :

From: Gennaro Prota (gennaro_prota_at_[hidden])
Date: 2006-07-24 09:24:32

On Sun, 23 Jul 2006 20:15:57 -0400, "David Bergman" <davidb_at_[hidden]>

>I like the idea of having such a (meta) construct in my programming
>portfolio, much like the "newtype" in Haskell

Not a bad name, though maybe a bit generic :-)

>Thus, its name should reflect that wider scope, such as

This begins to put more stress on operation and relation preserving.
And with the _type suffix it suggests a typedef in existing C++

[ Gennaro Prota, C++ developer for hire ]

Boost list run by bdawes at, gregod at, cpdaniel at, john at