Boost logo

Boost :

From: Dan Notestein (dan_at_[hidden])
Date: 2006-08-18 15:59:09

Yes, subobject is definitely the term I was looking for. Hadn't seen this
thanks for pointing it out!

----- Original Message -----
From: "Larry Evans" <cppljevans_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Friday, August 18, 2006 2:52 PM
Subject: Re: [boost] [Serialization] Proposal for improved support for ptrs to
contained objects + array data

> On 08/17/2006 04:18 PM, Dan Notestein wrote:
> > The current implementation of serialization has some limitations when
> > handling contained data that I would like to remove. By contained data,
> > I mean data that exists inside the allocated boundary of a containing
> > object that is also being serialized.
> I've got another problem which required a definition of "contained data"
> only I called it "iterior data". However, then I remembered:
> which suggests "subobject" maybe a better term. Would it be desirable
> to use "subobject" in your description instead of "contained data"
> in order to avoid a proliferation of aliased terms?
> [snip]
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at