Boost logo

Boost :

From: Janek Kozicki (janek_listy_at_[hidden])
Date: 2006-08-24 05:12:20

Matthias Troyer said: (by the date of Thu, 24 Aug 2006 13:17:09 +0900)

> Well, as a physicist for me 1 J and 1 Nm are the same. I would reject
> and never use a library that forces me to distinguish physically
> identical quantities just because I use a different name for the unit.

fully agree, distinguishing between torque and energy is artificial. And
just look how much complications it adds to the library! Whole new
concept of anonymous_quantity, serialization (outputting units values)
burden, etc...

Displaying a unit using correct unit should be left up for the user - he
chooses what name he wants displayed. The library could only take care
to correctly convert the value for output requested so that it matches
required unit - eg. passed as a string: "kNm","Nm","J","kWh" or "kg m^2 s^-2"

Janek Kozicki                                                         |

Boost list run by bdawes at, gregod at, cpdaniel at, john at