Boost logo

Boost :

From: Manfred Doudar (manfred.doudar_at_[hidden])
Date: 2006-09-14 22:08:31

On Thu, 14 Sep 2006 18:49:13 -0700
Geoffrey Irving <irving_at_[hidden]> wrote:

> On Fri, Sep 15, 2006 at 11:21:16AM +1000, Manfred Doudar wrote:
> > > Same with inner_product. dot_product is way cooooler.
> >
> > If your dot product is indeed an inner product, then an
> > inner_product is what you should call your op - being explicit
> > rather than suggestive is always better (, sorry, just that my
> > mathematics grounding makes me speak out on this one).
> Actually, dot_product is more specific, and therefore a better name:

Hmm, I knew that comment would get me into trouble; but was kind-of
in two heads/minds when I wrote that - indeed a dot-product is more
"specific", yes ... you are limited to operations of addition
and multiplication with a dot-product (effectively a constraint on the
kinds of spaces you are prepared to deal with), not so for its


Manfred Doudar - Research Engineer
National ICT Australia - Canberra Research Lab |
Research School of Information Sciences and Engineering (RSISE)
The Australian National University - Canberra, ACT 0200 AUSTRALIA

Boost list run by bdawes at, gregod at, cpdaniel at, john at