From: Geoffrey Irving (irving_at_[hidden])
Date: 2006-09-14 21:49:13
On Fri, Sep 15, 2006 at 11:21:16AM +1000, Manfred Doudar wrote:
> > Same with inner_product. dot_product is way cooooler.
> If your dot product is indeed an inner product, then an inner_product
> is what you should call your op - being explicit rather than suggestive
> is always better (, sorry, just that my mathematics grounding makes me
> speak out on this one).
Actually, dot_product is more specific, and therefore a better name:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk