Boost logo

Boost :

From: Yigong Liu (yigongliu_at_[hidden])
Date: 2006-10-04 02:18:54

Hi Shams,

On 10/3/06, shams <shams_at_[hidden]> wrote:
> I think "name space" should be called "namespace" or "Namespace".
> This is what most ppl are familiar with.

I have struggled with it. Originally it is called "namespace" in code and
doc. However C++ compiler complains about it and one of the feedback from
list thought it confusing too. I thought about other alternatives: "id
space" or "message space", none of them satisfactory. So i am calling it
"name space" or name_space for now. It is open for suggestions.

Regarding executors in topic "5.3 executor related".
> a. Are those described executors built-in to your library or are they
> just samples?

Yes, they are inside the library. From my last night's snapshot, you'll find
all of them under boost/channel/executors. I coded them in a rush as proof
of concepts to test out the framework. Some of them are really simple and
dumb. Samething with queue. However both executors and queues are template
parameters (of channel or dispatcher) which you can easily substitute with
your favorite implementations with thin wrapping to translate the API. One
example is the asio_executor which is a simple wrapper over ASIO's so that when channel is used with ASIO, the callbacks can
be dispatched to ASIO's main thread to execute. Since there is no single
executor or queue implementation satisfying all, my focus has been proper
framework setup to allow easy plug and play of various implementations.

b. Your thread_pool_executor compared to
> (also based on boost), how is it different/similar?
Again my thread_pool_executor is a simple prototype. The threadpool project
you mentioned above looks good. From browsing the documentation, i feel it
should be very easy to write a simple wrapper and use it together with
Channel. I just download the code and start playing with it. Thanks for
bringing it up.

Thanks for your comments.


Boost list run by bdawes at, gregod at, cpdaniel at, john at