Boost logo

Boost :

From: Martin Knoblauch Revuelta (mkrevuelta_at_[hidden])
Date: 2006-10-27 16:23:45

On 10/26/06, Jason Hise <0xchaos_at_[hidden]> wrote:
> [..] I think it should be renamed to something that
> reflects the strengths of the container, rather than after the
> implementation structure. (Not sure what a good name would be, but
> something to think about).

This is one of the first things I have wanted to discuss. I named it
avl_array one and a half year ago, when I made the first C
implementation, with the idea of thinking a better name someday...

AVL: impementation-specific. Bad name
Array: can give a wrong impression of how iterators work. Bad name
Tree: the tree is vital, but it is not used as a tree. Bad name
List: there's a list, but it is like a roller coaster. Bad name
Log: will be confused log files. Bad name
Thing: hummm

Rank tree is at least as good as avl array, of course.

I woud like a name focused on what it provides: a sequence, random
access, insertion/deletion, logarithmic complexity, alternative index
derived from the sum of 'widths'...


Martin Knoblauch Revuelta

Boost list run by bdawes at, gregod at, cpdaniel at, john at