Boost logo

Boost :

From: JOAQUIN LOPEZ MU?Z (joaquin_at_[hidden])
Date: 2007-03-17 16:21:14

----- Mensaje original -----
De: Steven Watanabe <steven_at_[hidden]>
Fecha: Sábado, Marzo 17, 2007 9:13 pm
Asunto: Re: [boost] [intrusive] Review
Para: boost_at_[hidden]

> Ion Gaztañaga <igaztanaga <at>> writes:
> > > I don't think that current is a good name for the function
> > > that gets an iterator from the value_type. How about something
> > > a little more descriptive like get_iterator, iterator_from, or
> > > to_iterator?
> >
> > "iterator_from" sounds good.

What about "iterator_to"? I don't get the rationale for
the "from" suffix. If i is an iterator and *i==x, one
usually says "i is an iterator to x", right?

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at