From: Jeremy Maitin-Shepard (jbms_at_[hidden])
Date: 2007-03-17 18:57:02
"JOAQUIN LOPEZ MU?Z" <joaquin_at_[hidden]> writes:
> ----- Mensaje original -----
> De: Steven Watanabe <steven_at_[hidden]>
> Fecha: SÃ¡bado, Marzo 17, 2007 9:13 pm
> Asunto: Re: [boost] [intrusive] Review
> Para: boost_at_[hidden]
>> Ion GaztaÃ±aga <igaztanaga <at> gmail.com> writes:
>> > > I don't think that current is a good name for the function
>> > > that gets an iterator from the value_type. How about something
>> > > a little more descriptive like get_iterator, iterator_from, or
>> > > to_iterator?
>> > "iterator_from" sounds good.
> What about "iterator_to"? I don't get the rationale for
> the "from" suffix. If i is an iterator and *i==x, one
> usually says "i is an iterator to x", right?
I understand your point, but I believe the idea behind the name is that
the function returns an iterator from a reference to an element.
I'll throw out another possibility: iterator_at.
-- Jeremy Maitin-Shepard
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk