From: Steven Watanabe (steven_at_[hidden])
Date: 2007-03-29 13:48:30
Matthias Schabel <boost <at> schabel-family.org> writes:
> >> Mathias, for this reason quantity_cast should be
> >> quantity_cast<quantity<SI::force> >(q)
> >> Agreed?
> I'm actually wondering if we can completely eliminate quantity_cast -
> with the new quantity_reinterpret_cast and the new conversions
> including value type, it seems like it is redundant. If so, I'd
> rather just get rid of it...
I actually prefer to use quantity_cast instead of
quantity_reinterpret_cast. After all, the behavior
of reinterpret_cast is unspecified except that
certain conversions are reversible, while
quantity_reinterpret_cast is always well-defined.