Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2007-05-17 08:20:55

Shams wrote:
> Hi,
> If you document...
> Does this mean you officially approve of iter_find and iter_split
> to usuable in production code?

This was alredy discussed a long time ago. I have nothing against.

The whole point of hiding them was raise in the review, when
iterator-base approach was considered to be superior.

However from the user responses it seems, the iter_find/split
approach is also quite useful.

> How about renaming them to iterator_find and iterator_split
> then :-)

iter is an abrevation of iterative, not iterator. It has actualy nothing
to do with iterators.


Boost list run by bdawes at, gregod at, cpdaniel at, john at