Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2007-05-24 16:10:34


Matias Capeletto skrev:
> On 5/24/07, Thorsten Ottosen <thorsten.ottosen_at_[hidden]> wrote:

> If bm is const I think we have to write:
>
> boost::sub_range< const bm_type::map_by<name> >
> r = bm.by<name>().range(...,...);

right.

> that it is not bad anyway.
> But I really like the look of the following code:
>
> bm_type::map_by<name>::const_iterator_range r = bm.equal_range(...);
>
> bm_type::map_by<name>::iterator_range r = bm.range(...,...);
>
> Are you against provide these typedefs?

not at all.

> (maybe with another name: sub_range, range, range_type)

simply "range" and "cont_range" is more concise IMO. The relation to
iterators is immplied.

-Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk