Boost logo

Boost :

From: Matias Capeletto (matias.capeletto_at_[hidden])
Date: 2007-05-25 01:25:06


> > But I really like the look of the following code:
> >
> > bm_type::map_by<name>::const_iterator_range r = bm.equal_range(...);
> >
> > bm_type::map_by<name>::iterator_range r = bm.range(...,...);
> >
> > Are you against provide these typedefs?
>
> not at all.

Ok, I will add them.

> > (maybe with another name: sub_range, range, range_type)
>
> simply "range" and "cont_range" is more concise IMO. The relation to
> iterators is immplied.

Boost.MultiIndex and Boost.Bimap defines a function "range(... ,
...)". We can not use the name range for the typedef... :(

I vote for range_type and const_range_type

( Note that we can not change the range function signature because
MultiIndex has use it for years )

Best regards
Matias


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk