Boost logo

Boost :

From: Austin Bingham (abingham_at_[hidden])
Date: 2007-10-03 10:39:41

On 2007-10-03, David Abrahams <dave_at_[hidden]> wrote:
> on Sun Sep 30 2007, "Phil Endecott" <> wrote:
>> Is "exception" the best choice of name for this library?
> I think the functionality of this library may be too specific to be
> given such a general name.

This was my main concern with the library, as well. As it stands,
the library consists primarily of a method for attaching
data to objects at runtime. This is a neat, well-thought-out
capability that I can imagine would be useful outside the realm
of exceptions. If this library were renamed (though a really good
name isn't coming to mind right now), it could of course still be
used in any future boost exception lib.

Austin Bingham

Boost list run by bdawes at, gregod at, cpdaniel at, john at