Boost logo

Boost :

From: Marco Costalba (mcostalba_at_[hidden])
Date: 2007-10-07 14:55:08

On 10/7/07, Miles Bader <miles_at_[hidden]> wrote:
> "Marco Costalba" <mcostalba_at_[hidden]> writes:
> > boost::overload<Signatures> f;
> >
> > // assign functions in any order
> > f.add_overload(foo4);
> Given that the entire point is to hold overloads, isn't "add_overload" a
> bit redundant? Why not just "add"?

Yes I agree, also because 'overload' is already the name of the struct
so perhaps add_function() would be better but also functors can be
added so....perhaps just add() is the best, util now ;-)


Boost list run by bdawes at, gregod at, cpdaniel at, john at