Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2007-10-24 10:53:24


Thorsten Ottosen wrote:
> Beman Dawes skrev:
>> Looks like the range fixes broke foreach. See
>> http://mysite.verizon.net/beman/bgd-win32-trunk-results.html
>
> This is my fault, sinc eI changed the names of the ADL hooks back to
> 1.34 names:
>
>
> namespace boost
> {
> char * range_begin(mine::dummy&) {return 0;}
> char const * range_begin(mine::dummy const&) {return 0;}
> char * range_end(mine::dummy&) {return 0;}
> char const * range_end(mine::dummy const&) {return 0;}
> }
>
> should be
>
>
> namespace boost
> {
> char * boost_range_begin(mine::dummy&) {return 0;}
> char const * boost_range_begin(mine::dummy const&) {return 0;}
> char * boost_range_end(mine::dummy&) {return 0;}
> char const * boost_range_end(mine::dummy const&) {return 0;}
> }
>
> The old names have been in use for so long that I don't see the point in
> changing them anymore.

I'm dumbfounded. Thorsten, how can you make an API-breaking change to a
core library like Range at a time like this, and not tell anybody? My
code, docs and tests would all need to change because of this.

!!!!!

We agreed long ago that range_begin() was the name of the customization
point, because the Range concept is larger than Boost. Has that changed?

Beman, what do you want to do?

-- 
Eric Niebler
Boost Consulting
www.boost-consulting.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk