Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2007-10-24 11:19:59

Eric Niebler skrev:
> Thorsten Ottosen wrote:

>>> We agreed long ago that range_begin() was the name of the customization
>>> point, because the Range concept is larger than Boost. Has that changed?
>> And that is the problem: do you want to break the few boost libs in a
>> development trunk, or break all clients out there? The names where
>> settled for maybe two years ago.
> Have you just changed the names of the adl hooks? There are lots of
> other breaking changes, like the changed meaning of range_iterator<>,
> the deprecation of range_result_iterator<> and the addition of
> range_mutable_iterator<>. And the behavior of range_end(char (&)[N]),
> too. Are you going to roll all of that back? If not, then you haven't
> really got a leg to stand on -- you're breaking clients anyway.
> This change is a mistake. Please, back it out.

oK. Done.


Boost list run by bdawes at, gregod at, cpdaniel at, john at