From: Eric Niebler (eric_at_[hidden])
Date: 2007-10-24 14:37:04
> Thorsten Ottosen wrote:
>>> This change is a mistake. Please, back it out.
>> oK. Done.
> Why not call boost_range_begin from range_begin?
Not a bad idea ... but this doesn't address the problem of the changed
meaning of the boost::range_iterator<> metafunction. (E.g., in your
scheme, what is the return type of range_begin()?)
-- Eric Niebler Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk