From: shunsuke (pstade.mb_at_[hidden])
Date: 2007-10-29 11:39:49
Thorsten Ottosen wrote:
> Single Pass Range:
> range_iterator<const T>::type
You mean range_mutable_iterator is no longer a public interface
but a customization point?
It seems a rational idea; "NVI" is always better.
range_iterator<remove_const<T>::type> might be cumbersome, though.
BTW, why not remove range_size<> from RandomAccessConcept,
which is utterly useless, and even wrong around iterator range.
-- Shunsuke Sogame
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk