Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2007-10-29 12:24:42

shunsuke skrev:
> Thorsten Ottosen wrote:
>> Single Pass Range:
>> types:
>> range_iterator<T>::type
>> range_iterator<const T>::type
> You mean range_mutable_iterator is no longer a public interface
> but a customization point?


> It seems a rational idea; "NVI" is always better.


> range_iterator<remove_const<T>::type> might be cumbersome, though.

well, it shouldn't be neede that much.

> BTW, why not remove range_size<> from RandomAccessConcept,
> which is utterly useless, and even wrong around iterator range.

I'm all for removing it.

Why do you think it's wrong?


Boost list run by bdawes at, gregod at, cpdaniel at, john at