Boost logo

Boost :

From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2007-10-30 16:00:30

shunsuke skrev:
> Thorsten Ottosen wrote:
>>> It seems a rational idea; "NVI" is always better.
>> nvi?
> Non-Virtual Interface. Say, Non-Specializable-Metafunction in this context? :-)
>>> BTW, why not remove range_size<> from RandomAccessConcept,
>>> which is utterly useless, and even wrong around iterator range.
>> I'm all for removing it.
>> Why do you think it's wrong?
> `boost::size(make_iterator_range(...))`
> would copy range_difference<...>::type into std::size_t.

If the requirent is that the secnd iterator is reachable from the first,
there is no problem.

> boost::make_unsigned<> might help, but
> anyway it is unneeded to force range_size<> specialization.

I think I agree. Do anybody what to argue for inclusion of range_size<>
in the concept?


Boost list run by bdawes at, gregod at, cpdaniel at, john at