From: shunsuke (pstade.mb_at_[hidden])
Date: 2007-10-29 12:49:50
Thorsten Ottosen wrote:
>> It seems a rational idea; "NVI" is always better.
Non-Virtual Interface. Say, Non-Specializable-Metafunction in this context? :-)
>> BTW, why not remove range_size<> from RandomAccessConcept,
>> which is utterly useless, and even wrong around iterator range.
> I'm all for removing it.
> Why do you think it's wrong?
would copy range_difference<...>::type into std::size_t.
boost::make_unsigned<> might help, but
anyway it is unneeded to force range_size<> specialization.
-- Shunsuke Sogame
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk