Boost logo

Boost :

From: Anthony Williams (anthony_w.geo_at_[hidden])
Date: 2007-11-02 11:15:12

Roland Schwarz <roland.schwarz_at_[hidden]> writes:

> Beman Dawes wrote:
>> I strongly suggest we use the name "interruption". That appears to be
>> much more acceptable.
> I recognized this quite some time ago already and tried to suggest
> "alert". Because this is what the suggested mechanism really means.
> "Alerting" a thread means causing it to throw an exception when in
> an alertable state.
> While interrupt describes also what the mechanism is about to do, the
> name is overloaded with HW interrupt semantics already. Personally I
> think it should be avoided as for this reason.
> Not trying to mix alertion with cancellation, so was my hope, would
> reduce the risk of misunderstanding. Of course it is possible to turn
> alertion into cancellation on the user-side easily.
> But, my suggestion went by almost unrecognized. Perhaps this is a new
> chance?

I didn't see your previous suggestion to use "alert" rather than
"cancel". However, I do like interruption, and I have renamed cancellation to
interruption on trunk.

I know there is a potential conflict with the use of the term with hardware
interrupts, but it is consistent with Java and .NET


Anthony Williams
Just Software Solutions Ltd -
Registered in England, Company Number 5478976.
Registered Office: 15 Carrallack Mews, St Just, Cornwall, TR19 7UL

Boost list run by bdawes at, gregod at, cpdaniel at, john at