Boost logo

Boost :

From: shunsuke (pstade.mb_at_[hidden])
Date: 2007-11-10 04:37:31

Thorsten Ottosen wrote:
>> Really, you're returning the difference_type and not the size_type?
> Yes, that was the intension. Iterators don't have a size_type per se,
> and so it complicated the whole thing a little to make the user worry
> about this.

I think that "size" was an inappropriate name.
I don't know why "distance_of_random_access" was named "size".
Iterators don't have a "size" per se. :-)


Shunsuke Sogame

Boost list run by bdawes at, gregod at, cpdaniel at, john at