From: Andrey Semashev (andysem_at_[hidden])
Date: 2007-12-04 10:59:52
Anthony Williams wrote:
> Anthony Williams <anthony_w.geo <at> yahoo.com> writes:
>> Currently, the boost::move in question is an implementation detail of
>> thread. It is an oversight that it is in the boost namespace and not the
>> detail namespace.
> I have now fixed this: I have renamed it to boost::detail::thread_move (and
Hmm... I guess that means users are not allowed to move Boost.Thread
components. That's a shame, because I was using this feature in my
Maybe moving to boost::threads namespace or just renaming them would be
a better solution?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk