Boost logo

Boost :

From: Phil Garofalo (philgarofalo_at_[hidden])
Date: 2008-01-05 00:44:49

Herve, my routines do include partial combination functions in addition
to the partial permutation functions. If my earlier work can contribute
to the addition of a good set of combinatorial functions for Boost, all
the better.



Hervé Brönnimann wrote:
> Ben, Phil: Merry Xmas (and to all on Boost.devel who read this thread)
> Phil: LOL!!!! My reaction was identical to last time, though, so I
> am true to myself :)
> Good to talk to you again. I'm interested in your reading of the
> proposal, and also your evaluation of the implementation. Looking at
> you 2002 post again, I see I had a few more ideas for motivation
> (enumerating determinant minors). Also, did you have an
> implementation of next_(partial_)combination? Or just
> next_partial_permutation (next_r_permutation in your naming scheme).
> Re: Names: I still don't like next_r_permutation, and think we've
> struck a better name with next_partial_permutation. Any other
> suggestions?
> Pending a few clean-ups and more testing I'll do following Ben's
> messages this week (I've got a few days off work) the plan is to
> submit something to the Standard Library Committee for the Bellevue,
> Wash. meeting, with C++0x as a target (or TR2 if if 0x is not feasible).
> For now, ciao,
> --
> Hervé Brönnimann
> hervebronnimann_at_[hidden]
> On Dec 23, 2007, at 11:33 PM, Philip Garofalo wrote:
>> Hello Ben and Herve, I'm not sure if you already know but there's a
>> previous
>> submission for combinations and permutations (mine) in the
>> sequence_algo
>> folder of the sandbox. In fact, Herve helped out! :-) I've been
>> away from it
>> for five years. Check out the discussion thread in the
>> archives. Nevertheless, I like your implementation. It's
>> interesting that
>> you chose a sorting method similar to mine, instead of using a
>> parallel
>> index array.
>> Phil Garofalo
>> On Dec 23, 2007 7:38 PM, Ben Bear <benbearchen_at_[hidden]> wrote:
>>> Sorry. I had lost too many times.
>>> 2007/12/6, Hervé Brönnimann <hervebronnimann_at_[hidden]>:
>>> My test showed that a bug exists in prev_mapping(). The last
>>> sentence
>>> of prev_mapping() should be "return false;", but not "return true;".
>>> Date of the tested combination.hpp is 2007-12-6.
>>> I'll put my test tonight. It mainly test the increment/decrement of
>>> the sequences and the returned flags.
>>> _______________________________________________
>>> Unsubscribe & other changes:
>> _______________________________________________
>> Unsubscribe & other changes:
>> listinfo.cgi/boost
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at