From: Giovanni Piero Deretta (gpderetta_at_[hidden])
Date: 2008-02-13 14:56:52
On Feb 13, 2008 7:12 PM, Stjepan Rajko <stipe_at_[hidden]> wrote:
> On Feb 13, 2008 8:47 AM, Steven Watanabe <watanabesj_at_[hidden]> wrote:
> > Thanks for the help. I think the best suggestions were control/control_flow
> > although I'm still not entirely happy with them.
> "control" does sound nice... also "flow_control"? "switches" sounds a
> bit odd at first but it kinda grew on me. I'm not sure whether there
> is a precedent for this in boost, but maybe "switchlib"? (that has a
> pretty fierce sound to it, like "switchblade" ;-).. although it
> certainly departs from the suggested naming convention). Or an
> acronym? "fcl" (flow control library?)... but that departs from the
> suggested convention too.
But there are precedents though, think mpl...
sl (switch library) wouldn't be bad, but maybe too short an collision prone.
> Another alternative altogether might be to find a good home in
> existing libraries/namespaces (utility? something else?) That of
> course depends on what the final switch library looks like, and the
> say of any library authors that would be involved.
+1 for utility, depending on how many names the switch library puts in