Boost logo

Boost :

From: Marco Costalba (mcostalba_at_[hidden])
Date: 2008-04-26 09:14:10

Ok I have uploaded in Vault a new version of with included the
feedback from Joseph and Matus.

> 1. Does "reset" sound like a better name for "unset"?

Added clear<signature>() for consistency with boost::function

Added clear_all() to clear all functions in one go.

> 2. How about providing a get<signature> method returning ref to the
> underlying boost::function object.



Added also an example on how multi signature function supports copy semantic

Thanks everybody, more feedback welcomed

Boost list run by bdawes at, gregod at, cpdaniel at, john at