Boost logo

Boost :

From: Fernando Cacciola (fernando_cacciola_at_[hidden])
Date: 2008-05-01 20:52:39

Johan Råde wrote:
> John Maddock wrote:
>> Johan Råde wrote:
>>>>>> floatdistance(lhs, rhs)?
>>>>> Would adding an underscore be nicer:
>>>>> FPT float_distance(FPT lhs, FPT rhs);
>>> How about discrete_distance?
>> That's not bad at all actually,
>> Thanks, John.
> To me the word distance suggests an unsigned quantity.
Same here, but...

> Maybe discrete_difference?
The word difference in the context of a numerical operation suggests a
numerical difference, so I feel that distance suits better here.

I like "representation_distance". To me it says exactly what it is. And I
would even call it "rep_distance" since 'rep' is a fairly common

Anyway, don't we want to also have the 'cousin' function:
"representation_advance", such that:

representation_advance(x,representation_distance(x,y)) == y

always holds for any x,y?

That identity makes it clear that the distance is signed.


Fernando Cacciola

Boost list run by bdawes at, gregod at, cpdaniel at, john at