From: John Maddock (john_at_[hidden])
Date: 2008-05-05 06:48:22
So, it looks like so far we have:
and either of
Whilst I'm normally all in favour of
"long_meaningful_names_with_underscores", next() and prior() do look OK to
me: especially so long as they're in namespace boost::math.
Like Paul, I'm still looking for the right "killer name" for the *_distance
function, I quite like "maddock_metric" but I doubt anyone will know what
that means :-)
Given that this function is inherently related to the "units in the last
place" metric, I wonder if we can compose a name from that?
Maybe extending the API slightly how about:
T upl_distance(T, T); // "representation distance"
T relative_distance(T, T); // AKA relative error.
T ulp(T); // distance between arg and next(arg)