Boost logo

Boost :

From: Michael Fawcett (michael.fawcett_at_[hidden])
Date: 2008-05-05 10:38:13

On Mon, May 5, 2008 at 6:48 AM, John Maddock <john_at_[hidden]> wrote:
> Given that this function is inherently related to the "units in the last
> place" metric, I wonder if we can compose a name from that?
> Maybe extending the API slightly how about:
> T upl_distance(T, T); // "representation distance"
> T relative_distance(T, T); // AKA relative error.
> T ulp(T); // distance between arg and next(arg)
> Thoughts?

I like these a lot. I was thinking about suggesting ulp_* names last
week but didn't want to get into a discussion on a subject I'm not
very knowledgeable about.

--Michael Fawcett

Boost list run by bdawes at, gregod at, cpdaniel at, john at