Boost logo

Boost :

From: Jurko Gospodnetić (jurko.gospodnetic_at_[hidden])
Date: 2008-05-19 12:38:31

   Hi again.

>> I renamed the local CRITICAL_SECTION to critical_section to avoid this
>> ambiguity. See revision 45545.
> Could you also add the comment from the original patch to explain why
> this has been done? Since there are no tests prepared that would catch
> this if it ever regressed...

   Also... the renamed class name as used in the original patch seemed
clearer since Visual C++ still has a bug with exposing this identified
in the global namespace... and 'critical_section' seems much more likely
to cause problems than

   Best regards,
     Jurko Gospodnetić

Boost list run by bdawes at, gregod at, cpdaniel at, john at