Boost logo

Boost :

From: Zach Laine (whatwasthataddress_at_[hidden])
Date: 2008-05-21 09:48:59

On Wed, May 21, 2008 at 8:44 AM, Frank Mori Hess <frank.hess_at_[hidden]> wrote:
> On Wednesday 21 May 2008 09:34 am, Zach Laine wrote:
>> This sheds their context. The linear sequence does not exist in a
>> vacuum. It is a sequence of nodes that defines a path through a
>> filesystem tree. When I think of a filesystem, I think of it as (a)
>> root node(s), interior nodes, and leaf nodes. The fact that I'm only
>> looking at a subset of them when dealing with a given path does not
>> change what kind of node each is conceptually. In short, I like
>> "leaf()".
> My impression from earlier posts, and the path decomposition table in the
> docs, is that leaf is a bad name because it can return an interior node in
> the filesystem.

Then the leaf referred to is still the leaf of a subtree of the
filesystem. I'm as into proper naming as the next guy. The point I'm
trying to get across is that the name "leaf()" seems very natural to
me. In fact, it has never given me a moment's pause.


Boost list run by bdawes at, gregod at, cpdaniel at, john at