From: Larry Evans (cppljevans_at_[hidden])
Date: 2008-05-21 12:54:24
On 05/21/08 08:48, Zach Laine wrote:
> On Wed, May 21, 2008 at 8:44 AM, Frank Mori Hess wrote:
>> On Wednesday 21 May 2008 09:34 am, Zach Laine wrote:
>>> This sheds their context. The linear sequence does not exist in a
>>> vacuum. It is a sequence of nodes that defines a path through a
>>> filesystem tree. When I think of a filesystem, I think of it as
>>> (a) root node(s), interior nodes, and leaf nodes. The fact that
>>> I'm only looking at a subset of them when dealing with a given
>>> path does not change what kind of node each is conceptually. In
>>> short, I like "leaf()".
>> My impression from earlier posts, and the path decomposition table
>> in the docs, is that leaf is a bad name because it can return an
>> interior node in the filesystem.
> Then the leaf referred to is still the leaf of a subtree of the
> filesystem. I'm as into proper naming as the next guy. The point
> I'm trying to get across is that the name "leaf()" seems very
> natural to me. In fact, it has never given me a moment's pause.
Would the term "pruned_leaf" be an acceptable compromise? The
"pruned_" prefix would imply the "context" you mentioned above as well
as "subset of them" [where them is nodes] mengioned above. In the
case that the node was an actual leaf (e.g. an actual file) then the
"size of the pruning" would be just 0, where "size of pruning" is the
distance to an actual leaf (where actual leaf means the same as leaf
node in this quote:
>>> When I think of a filesystem, I think of it as (a)
>>> root node(s), interior nodes, and leaf nodes.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk